Disabled admin plugin, can't re-enable

Hello,

I had an issue updating the admin plugin of my website, when updating it complained about the directory of the admin plugin itself not being empty.
I disabled the admin plugin from de web interface, not realizing that this would trow me out.

I went to cli with the hope to be able to re-enable the plugin.
in the admin.yaml file the plugin is enabled. I tried reinstalling the plugin with gpm/install plugin, to no avail.

when I try to reach https:///admin I get a 400 not found page.

How can I re-enable the admin plugin?

thanks,

Jona

A 400 error is odd. Is https:///admin a real thing?
400 Bad Request

The server cannot or will not process the request due to an apparent client error (e.g., malformed request syntax, size too large, invalid request message framing, or deceptive request routing).

Hi Simon,

The url is https://jonafoto.be/admin
it returns a 404. if you want to try

any log info I can give to determine the cause?

have you tried using the command line and doing

bin/gpm uninstall admin

or if on windows

php bin/gpm uninstall admin

then

 bin/grav install admin

again if on windows

php bin/grav install admin

With grav design, you can even just use a file manager and remove the admin directory and then reinstall it. HTH

I tried uninstalling using bin/gpm but the uninstall failed with the following error:

Cannot override frozen service “login”.

I tried manually removing the admin folder from the user/plugins directory
and then reinstalling using /bin/gpm install admin (to no avail)
I tried installing using /bin/grav but that seems to be for grav skeletons, not for plugins, or am i mistaken?

thanks,

Jona

I finally found and solved the issue,
apart from the admin.yaml file in user/plugins/admin/
there is an admin.yaml file in user/config/plugins/admin

this yaml file also holds a configuration option “enabled” to enable/disable the admin plugin, which was set to “false”
changing it to true resolved the issue.

1 Like