Crikey! on Grav 1.4.7 Administration Panel


#1

Crikey! on Grav 1.4.7 Administration Panel Error
I have installed Grav core + Admin plugin (Only if that makes a difference?)
I’m new to this cms, I have used WP, Joomla, Drupal, C5, Simple Machines, CMS Made Simple, I think a few others too. Their admins just works out of the box, Grav has a bug for me at least.

Arguments: “session_start(): open(/home/content/86/4795186/tmp/sess_cgb5s5cgi8cipcbt53s9qe2vl4, O_RDWR) failed: No such file or directory (2)”

/home
/content
/86
/4795186
/html
/GoDaddy Subfolder
/grav-admin
/vendor
/rockettheme
/toolbox
/Session
/src
/Session.php


#2

@k64 To help you get a better response then to the same issue you created last week, I searched on Google for some bug reporting guidelines.

The title of one of the guidelines says it all: How to write a bug report that will make your engineers love you.

Most guidelines have a few steps in common:

  1. A short but informative headline that includes a short description of the issue
  2. Description of environment.
    For instance, platform and software versions.
  3. When did you first notice the bug?
    For instance, after upgrading to version…
  4. Where does the bug appear?
  5. List the steps you take to reproduce the bug? Be specific.
  6. Can the bug be reproduced over and over or only sporadically?
  7. What are the exact error messages that you are receiving?
  8. Is there any other relevant error information to report?

#3

The PHP running Grav cannot start a session because it cannot write to the right folders, see docs on permissions.


#4

+1 @pamtbaau … and formatting!

Help us help you. We are not being paid!


#5

I’m all for more details in supports requests, but this is not a bug issue on the repo. From @pamtbaau’s well-sourced reply and the original post, we can infer the following:

  1. Grav is throwing a fatal error, which we know and love as the “Crikey!” dumps.
  2. From the other post, Linux on GoDaddy, incidentally shared.
  3. From the second sentence and original post, this is a raw installation of Grav + Admin (previously just Grav). The error would not occur on an upgrade unless PHP changed in between.
  4. On all pages where Grav spawns a session, by default it does it everywhere.
  5. Permission-lock PHP’s temp-folders, or change their location.
  6. “Bug” is visible everywhere and always, unless sessions are disabled.
  7. Lines 5-7 of the original post.
  8. Probably, particularly the permissions set on /home/content/86/4795186/tmp/ and php.ini in use by the PHP that runs Grav.

That level of detail, whilst helpful for a deep debug, is a bit over the top for something that should be quickly recognized as a PHP-issue. The keys being “Crikey!”, meaning Grav refuses to continue, the session_start() error, and the information No such file or directory.

@k64 The aforementioned permissions in the docs should be examined, and if that does not help you need to find out why PHP cannot create or write to its temporary-folders. If you are unfamiliar with configuring PHP, or do not have access to it on your shared hosting (which is uncommon), contact your host. Even GoDaddy once upon a blue moon gets on of its technicians in for a helping hand.


#6

Found the problem with GoDaddy… “Legacy Hosting” w/ outdated php version. Grav CMS is now working since everything was updated… (*Need to add PHP Zip Support under [Select PHP version] in cPanel).

All I need to do is figure out how move user pages & blog to the root sub-directory that does NOT include ‘grav-admin’ in the URL… :thinking:


#7

QA testing is our everything. I’m a newbie in the field, in search of the solution to a similar problem bumped onto this thread. Find it useful. Thank y’all