Changed favicon does not show in browser

I’m trying to change the standard favicon. I’m on standard Quark template
on /user/themes/quark/templates/partials/base.html.twig I’ve

<link rel="icon" type="image/png" href="{{ url('theme://images/favicon.png') }}" />

at */user/themes/quark/images/

  • My favicon (favicon.png) in place of original one
  • grav-logo.svg (the original logo)
  • the folder logo with my logo (that’s working) and an empty file (.gitkeep)

I’ve cleared the cache & browser but no change appear. Still the Grav favicon

@veehem, I’m sorry, but I cannot reproduce the issue…

  • Replaced the file user/themes/quark/images/favicon.png with a new image using copy/paste on filesystem.
  • New favicon was shown immediately in tab of browser.
  • Restored the original favicon using Git.
  • Favicon did not show immediately in tab of browser. Needed to refresh cache of browser.


  • Did you use Ctrl+F5 to clear the cache of the browser?


  • You should never ever change/remove/add anything to a theme or plugin which comes with Grav, and/or is installed via GPM. All changes will be removed when the theme gets updated.
    Use a child/inheriting theme instead.
1 Like

@veehem, Please do not ghost a reply, but share your progress…

Thanks to care of it @pamtbaau I didn’t forget. Someone seems to found the solution, but I (still) don’t know how. I’ll be back when I know

@pamtbaau I turne around…
I guess there is a problem with initial theme installation.
I started everything again but when I’m trying to install your suggested theme grav-skeleton-onepage-site+admin-2.0.0, I’ve now an error Installation failed: Not a valid Grav package
Any Idea what’s happen with me, bad luck or witchcraft?


I’m trying to install your suggested theme grav-skeleton-onepage-site+admin-2.0.0


By direct install. I’ve tried both 1/after having download the zip and 2/ via Remote URL Reference
I’ve tried to install Home | Gateway
No problem but the complete setup of the home page wasn’t there, so I prefer to try with SkeltonOnePage


By direct install.

I was afraid of that… A skeleton is not a theme and cannot be installed via Admin. It is a zip file containing a complete Grav installation + the theme + demo pages + demo config.

You will need to unzip the skeleton in the root of the site using $ unzip path/to/ . to unzip it in the current directory.

thank you @pamtbaau It’s probably the reason of the initial error: installing some pages from SkeltonOnPage directly by FTP

@veehem, You’ve marked your last reply as solution.

Do you mean you have a working Grav installation and your changed favicon is showing in the browser? If so, please share why it didn’t show up in the first place and what steps you’ve taken to solve the issue.

I didn’t solve anything. I guess I made a mistake with my initial installation. Now I’m starting everything from a tabula rasa :face_with_spiral_eyes: