Grav/gpm under Windows seems broken

Just tried to use bin\grav and bin\gpm. Got stuck with an error regarding unknown eval function. I remember we already had this some time ago. You fixed this then, but now its the old problem again.
I tried to run the commands with “php bin\grav” and “php bin\gpm”.

Try running php bin\grav install. This results in
"ERROR Missing .dependencies file in user/ folder
ERROR invalid YAML in .dependencies"

You either need to add your php.exe to your path (google it), or prefix all your commands with the full path to it:

c:\php\is\installed\bin\php.exe bin/gpm index

Obviously it depends how you installed and are using PHP, so find the appropriate path to the exe first. Better to add it to your path though as this will get old!

Hey Andy,
I tried both, adding PHP to the environment and also using the full executable path. I might add that I have no problem on Windows 7 here, but the PC where we have the problem is running on Windows 10. Although I can’t imagine why this would make a difference I also tried different PHP Versions - everything from from 5.4 to 7 beta - but to no avail.

Should make no difference if its windows7, 8 or 10. However it does matter what your using for your PHP. Each WAMP server system has it’s own paths to these files.

I don’t use any special WAMP Server as such. Only a simple PHP installation with path set. The GRAV sites seem to run fine, as do a lot of other databaseless systems.

when I try to install a theme… this is what I get:

Preparing to install Machine [v2.0.5]
|- Downloading package… 0%

Error while trying to download ‘

I can call this by entering:
U:\GRAV-PHP\www\grav-blog>… ools\php\php.exe bin\gpm install machine

or (PHP is also in my path)
U:\GRAV-PHP\www\grav-blog>php.exe bin\gpm install machine

or even:
U:\GRAV-PHP\www\grav-blog>bin\gpm install machine
since there’s also a batch gpm.cmd inside the bin folder.

php version is currently: 5.4.45, but up to 5.6.x it’s the same problem.
Am I missing a certain PHP module here?

Finally I found it. It seems the PHP openssl extension was missing here. Andy, couldn’t you check for the essential PHP modules in your scripts and warn us if those libs aren’t loaded?
I guess this also prevents the admin GUI from working (Had no warning here either).

Good idea :slight_smile:

Cool. Thanks a lot :slight_smile:

ensure extension=ext/php_opensll.dll enabled in whereever:\php\php.ini

php bin/gpm install whatever

Well… This is what we just talked about isn’t it