"Cannot connect to the GPM" error in admin

I just installed Grav + admin plugin on a shared hosting, everything seems to work fine except this warning that I see when I login to the admin page. When I continue to install for example a theme I get a Grav error page with error " Whoops \ Exception \ ErrorException (E_ERROR) Call to a member function filter() on null" with a piece of php code from “/httpdocs/user/plugins/admin/classes/admin.php” with this line highlighted: “return $local ? $gpm->getInstalledThemes() : $gpm->getRepositoryThemes()->filter(function ($package, $slug) use”

Of course I did some research on this problem but I can’t make it work with any of the given solutions. I’m using PHP 5.6.19 with cURL support and openssl enabled. Other things I read that can cause this problem are permissions issues. Lots of solutions are given using shell commands, but I’m unable to use these on my hosting. To exclude as many permission issues as possible I unpacked the grav zip using a PHP script and when that still gave the same issue I manually tried to fix the permissions using Filezilla according the commands described here.

Still no luck, so what can I do now?

First are you sure you cannot use SSH? Most hosting setups (even shared hosting) have SSH available. You might have to enable it or ask support to enable it, but it will make things much easier to debug.

The hosting company explicitly states that it’s not possible to use SSH.

Ok can you confirm that Curl and OpenSSL is listed in the config -> info panel? In fact can you paste that PHPInfo output into a https://gist.github.com/ and paste the link?

Of course :slight_smile:

Well i don’t see any obvious issues. Please open up an issue here: https://github.com/getgrav/grav-plugin-admin/issues