Cannot connect to the GPM

Downloaded grav+admin package and run localhost/grav-admin in Wampserver 64-bit for Windows.
Register new user screen appeared with a 'Cannot connect to the GPM’
It disappeared in a few seconds but it happened again and again when browsing admin sections.

Is the openssl php extension installed?

php_openssl appears to be enabled in PHP extensions.

CURL too? are you behind a proxy?

It is a local Wampserver installation and php_curl is also enabled.

And proxy is bypassed for localhost

Adding a plugin in that case outputs
Whoops \ Exception \ ErrorException (E_ERROR)
Call to a member function filter() on a non-object

I wander if it’s related to the default param_sep option? Try changing it?

Unfortunately neither of the problems are resolved.

I’ve had the same issue on my apache server (running on debian) after upgrading to 1.0.8. After some research I’ve found that the CA certificates weren’t installed. Might be worth looking into this.

Still the same with Grav 1.0.10.

@smel are you sure the proxy is bypassed for localhost? can you disable it temporarily? Can you try setting the proxy setting in Grav’s user/config/system.yaml (this was added recently)

I had a solution to this. I should have documented somewhere. I believe it was due to permission issues with some file/folder.

I already have Gav on one of my domains on the server and I just tried to install on another domain on the same server here I get the issue.

The old website is working.

Most probably permissions of the cache folder?

I already tested the cache folder with 755, 777 which doesn’t help. It could be a subdirectory in cache.