Cache policy


I’m just starting with Grav and it looks promising.
I have activated the admin plugin and when i enable cache in configuration, the admin part is impacted by the cache policy. For example, i have to wait some minutes before the new folders created appear. Only frontoffice should be impacted when enabling cache.

I have checked if my environnement (Mac os X with a vagrant VM and a NFS share) was the problem but it isn’t.

The problem is really that expires meta send for admin page apply caching policy (so by default expires in 7 days).

By default Grav checks every single page load to see if something has changed, if it has, the cache is updated. Can you post a gist to your system.yaml so I can see what you have changed?

The other option is you have some webserver level cache configurations that is causing your browser to not even request new versions for 7 days.

Here is my system.yaml
Cache has been turned off for the moment.

It could be the last_modified and etag which you have turned on. Both of these tell the browser to not even look for changes. Set those both back to false.

Ok thanks for your response. So there is not way to have frontoffice pages using cache while admin pages do not have ?

Currently no, please create an issue on the Admin tracker if you feel there is a need for this: