Blog not showing on live server, gives 403

Hi, i recently moved my grav page online, but now the blog is not showing. It gives me a 403 Error, complaining that it has no index directory/file. The only workaround i found so far, is appending a “.html” to the blog page. The problem then is, that all other URLs are nice and clean, so the “” looks like a flaw/error and stuff like that bothers me.

Any Ideas, how to fix that? I used the anitmatter blog page as a preset for my own. The other pages on the website are working nice, so i guess it has to do a) my server or b) the blog page/template. Since my options are limited concerning the server, i hope grav can handle the issue. Any suggestions?

Which webserver are you using? Did you upload the corresponding default configuration file for your specific web server?