Bin/plugin command issues

I am following the Grav Theme Tutorial and have installed the DevTools plugin, however when I use the Grav CLI command:
“bin/plugin devtools new-theme” nothing happens and it exits.

I have just started using Grav to test it out and installation went smoothly. The plugin seems to be correctly installed as well. I am in the root folder with the Grav installation, have checked that PHP is installed, and changed permissions for the directory.
I have tried using other plugin commands and the same thing happens.

it’s a whole ‘thing’ getting the cli to work natively in windows. and it’s not very well documented (for windows users) if you ask me, but the best advise i can offer is to make sure you’re using the local server shell instead of the global shell. IE: XAMPP shell vs. power shell.

Thanks for the suggestion! Although I’m not sure yet if it applies to me since I am using PuTTY to access the host server. I did just try it out on a XAMPP server and it seems to work there (after including the path to the PHP executable), but I was hoping to use it through my hosting service.

Would be really great if a windows user provided some great instructions for getting the CLI to work. The core team are mac users and linux users so it’s not really our strong suit. We have tested and got it working, but I don’t even know if it’s the best way, or the windows-way of doing things.

There has to be some experienced developers out there who use windows that can write up some clear and concise instructions? Please help!

Thanks for the response, but I’m not really sure yet if this is a windows issue. I am using a windows machine, but I am accessing a remote host that is running on Linux and using the CLI through there.

So when you say nothing, there’s no output?

Also, what happens if you try to run PHP from the CLI with:

php -v

It should report its the CLI version.

serverpilot@grav:~$ php -v
PHP 5.6.25 (cli) (built: Aug 19 2016 00:37:40)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with Zend OPcache v7.0.6-dev, Copyright (c) 1999-2016, by Zend Technologies

If it reports CGI, or FastCGI or something like that, then it’s the wrong version, and you will need to fix that in your path or maybe even a symlink. Really depends on your host, and frankly it a hosting issue that your hosting company should fix for you.

There is no output, and it exits (see screenshot 1). I think it is supposed to prompt me with questions.
I checked the PHP CLI version again, and I don’t see CGI or FastCGI (screenshot 2). I do suspect that it might be an issue with the host since it worked on a local server. 1 2

Do you get any feedback if you just type bin/plugin and bin/plugin devtools?

bin/plugin devtools has no feedback, but bin/plugin will list usage, an example, and plugins with CLI available.

is it just devtools not working for you? What about bin/plugin error ?

I suspect its something related to those extensions loaded in the PHP configuration… Ioncube, Zend Guard Loader, and Suhosin.