Unable to use cli commands, keep getting Curl Errors

I’ve install the latest version of GRAV CORE + ADMIN PLUGIN, I am using Mamp on a windows PC.

I am running PHP 5.6.24, when I view the phpinfo and the grav configuration page I can see OpenSSL support and cURL support are both showing as enabled. I also have GIT for windows and GIT Bash installed. I have turned of fopen as advises in the trouble shooting section.

However when I try to run any commands that use GPM I get the following error:

FATAL: DEVTOOLS requires PHP Curl module to be installed

I am unable to install a theme using the devtools command and I can’t see that there is any other way to create a blank theme from scratch, all the documentation talks about using the cli which I am unable to get working.

It is worth mentioning that before installing mamp (for php 5.5) I was using xampp for other projects so I don’t know if something to do with the system paths are conflicting.

Anyone have any suggestions?

So if you type php -m at the command line, the module curl appears in the list?

I’ve just tried running that command and no Curl doesn’t appear in the list which is even more confusing. Any suggestions how I get it to appear?

Are you sure you are running the Mamp version of PHP from the command line? What if you run C:\windows\Mamp\php\php.exe -m (or whatever the actual path is).

I’ve just doubled check and it appears so, this is where MAMP is running PHP from


When I run the following from the command line

F:/MAMP/bin/php/php5.6.24/php.exe -m

I am getting the same list of modules which doesn’t include curl. Its really frustrating as this isn’t technically a grav issue but it is stopping me from using grav.

You probably just need to find the .ini file for MAMP’s PHP, and then search/find/edit the line for the curl extension and remove the comment at the start of the line.

BTW, the mac version comes with Curl for the CLI, so not sure why the windows version doesn’t. Could try asking on the MAMP forums if you can’t sort it.