Admin plugin on remote host: no access to css-files

I am trying for a few hours now but i don’t seem to get it to work.

I have downloaded a fresh copy of grav + admin and uploaded it via ftp to my webhost.
front end works fine, so I assume that mod_rewrite is enabled. directory permissions are set according to the permissions page.

if i open the site I am redirected to the admin create user page, but i get several browser login prompts because the css and js files inside the admin panel theme are not accessible. if I try to access them via source code, I get a 404

i don’t know what else i can do. please help.

Can you please PM me the URL so I can see for myself. It’s kinda hard to give you an answer at this point.

Well it seems you’ve changed the default path for /admin to a unique name. That’s totally fine, but perhaps you have explicitly blocked paths in your .htaccess (or equiv) because all the links to the plugins JS and CSS are not found:


This is getting a 404, so either your webserver is configured to issue 404 for any user/ links, or somehow you have configured these files to not be in your web root?

Either way, definitely something you need to fix in your webserver/setup configuration.

totally agree with you. but i did not mess up anything in the .htaccess or any other configuration file. my first attempt was to check if mod_rewrite is up and running on the host but that seemed to be fine,because the frontend works as expected.

the webspace hosting company has set de default directory of webpages to /web on the ftp directory. do i have to rewrite the base to /web/ in the .htaccess then?

and yes, i changed to route to the admin plugin. that fixed the error of the continous login prompts. but exactly this is the problem i think. when i do not change the default route from /admin to /ce, i get those login prompts.

and the /user directory should be accessible for the browser because the frontend is a custom theme i built for this page. and the frontend is showing up correctly.

sry for typos - i’m on my cell …

@remidesigns Custom admin routes are working. I guess in your case it is not working because Grav thinks /ce is a language and (I guess without having tested it) strips it from the URL. Try another one. May be abcd.

ok i’ll try. thx

Grav would only think it was a language if you configured it that way in supported languages setting.

This is an extract of the error.log in the webspace of my client:

[Wed May 25 11:47:19.861709 2016] [auth_basic:error] [pid 29147] [client] AH01618: user remidesigns not found: /admin/config/system, referer:

remidesigns is the user i have created for the admin panel
the error is thrown by a login prompt that appears when trying to access a page inside the admin panel.

I have downloaded a plain version of grav core + admin plugin and uploaded it to the server (to ensure, that my code is not the problem) - still no luck :frowning: somebody help me please …

I’m not sure, but maybe it has something to do with your theme folder.
The request are made to

(note the themes/grav)
Whereas on working pages, the request are made to

Nevermind my previous answer, that’s not it, admin page request different assets than frontend. The path is correct.

Just wanted to inform you that the problem is solved. the web hosting company has implemented an apache directive, where all files/folders on their client ftp directories containing admin within their file/foldernames are restricted by auth basic. they gave me the username and password and everything worked fine - the only workaround is, that grav lives now in a subdirectory of /grav - but that’s ok. i did a .htaccess redirect

Glad you got it sorted! You can also change the admin directory to be something else. Just change the value in the admin plugin properties.

that was my first attempt but that does not change the relative paths (exactly, the “theme_url” variable in twig) in the source code. you saw it yourself.

the admin interface had been routed to (via admin plugin properties) - but in the source code, there were 404-errors according to the css/js files.

and also, the changed route is (if I understand right) some sort of alias, right? that would not solve the problem with the login prompts, except it does really rename the plugin folder. as long as there is a directory of admin, they block it with auth basic.

but as already said: my client is happy, so I am happy! :slight_smile: