Access Grav From Base URL Rather than Subfolder


#1

I feel like I’m missing something very obvious here, but have been chasing my tail in circles for a couple of hours and felt it’s about time I tried a more direct approach :smiley:

So I’ve setup a new root holder on my webhosting platform (root/portfolio) and have pointed my domain name at that folder (murrayadcock.co.uk). I’ve tested this part of the setup is working correctly by chucking a basic index.HTML file in there and having it display without issue.

The next step is to install Grav, which I want to use as the backend for my portfolio. I’ve downloaded the core + admin zip file, uploaded it to the root/portfolio folder and extracted it. But if I go to the website, I just get a 404 not found error. So where am I going wrong? Do I need to configure some other files first? Would love to get this running!

EDIT: Okay, some progress, I found that I can access the Grav setup panel from _murrayadcock.co.uk**/grav-admin**, which is a start. I’ve setup an admin login and all the pages work, so my next question is how do I get the url to go directly? I’ve tried moving everything up one level, out of the grav-admin subfolder, but that broke everything again. I’ve also tried setting the custom base url to “murrayadcock.co.uk”, both in the system.YAML file directly and via the admin panel. What else am I missing? Do I need to setup an .htaccess redirect?

FINAL EDIT: I’d still be interested to know what I did “wrong” with the above, but I changed absolute URLs in the admin panel to Yes and the install broke hard, so I just deleted it all and started from scratch. If anyone else finds themselves in the same issue, instead of extracting the install file into the portfolio subfolder, I extracted directly to the root of the webserver (not web root, at the same level as that) and renamed the subfolder once extraction was complete. Little unintuitive but at the end of the day I’m where I wanted to be :slight_smile: