404 not found with /random and /search

Is anyone else having issues with getting these modules to work properly? While doing local testing both of these pages lead to Grav’s 404 page. The documentation for either module doesn’t state that any routing changes need to be made. I haven’t made any changes to the default settings for either and am trying to use them on the “blog” section. Thanks!

Make sure the cause is not in this list

Hi, I’m also having a 404 issue, after reading the list linked by Flavio I would like to set “allowoverride” to all.

In which file can this allowoverride be found? I’m running on Rochen shared hosting.

never mind, issue resolved

Hey thanks for the response flaviocopes. I don’t think the cause is in that list, as I’m getting the grav page, but the pages are all routable.

Can this be due to routing issues even if I haven’t modified any of the pages’ routing settings?

For more information on this, I used the Gateway skeleton to build the site off of, and it looks like the simplesearch 404’s even on the demo website: Gateway Skeleton Demo

Ok that is an issue I fixed a couple days ago: https://github.com/getgrav/grav-theme-gateway/commit/6981178eb81bdd1612fa0ecb745292d5280e55ed - I need to issue a theme release. Not sure if it’s related to your issue though, as /random has no correlation with this.

Thanks. That fix fixed the issue with the search function.