404 on Mamp

Hi, I can’t get Grav to run subfolder pages locally on MAMP. It loads the main page fine but 404’s on any subpage I’ve created. Any ideas? It’s not running in a subfolder or anything but I tried to rewrite the base anyway a thousand times, but no cigar.


Are you running MAMP on mac or windows? Not sure it matters, as they should be configured similarly. I’ve used MAMP on both and never had any trouble that you are describing. I can guess what the problem is though.

My hunch is that you are either using an Apache virtualhost setting or have made a modification at some time that has:

AllowOverride None

Either for the default host, or the virtual host you are using MAMP Pro, you can check these via the admin. These are the default settings, and you can see AllowOverride is set to All.


If you are using regular MAMP you might have to edit the httpd.conf file manually.

You, sir, are a champion :smiley:


That was it? I’m getting good at this :slight_smile:

Yep. Epic win, thanks :smiley:

FYI was MAMP on Mac running regular mamp so I had to edit the .conf manually. It was actually that my httpd.conf root was set in a different location and I set the Grav install in a new location that didn’t have the override set to ALL.

Thanks again

FYI, and not to beat a dead horse, but there is a note about this in the docs already as it has come up before. Anyway, glad it’s sorted!

Clever… I did search the forum, but not the docs :smiley:

Thanks. What runs the search function for the docs out of interest?

It’s just the simplesearch plugin that’s available in downloads or GPM. However, there’s a bit of JS magic going on to filter the results. It’s all available on github if you are interested:

+1 thank you for AllowOverride setting