404 Error - Server 2016 IIS 10


I managed to install Grav Core with no issues on Server 2016 IIS10. I tried installing Core + Admin but i keep getting the 404 when i launch the website.

it goes to localhost/admin - i have installed URL Re-write.

I’ve tried installing the core, then installing the admin portal via BASH, but it still doesn’t work. It seems that anything other than localhost works if i add a forward slash to any sub pages, it goes to a 404 error page.

This definitely looks like a rewrite issue. Any ideas on how to fix?

Any have will be greatly appreciated.

404’s errors are usually caused by rewrite issues. Even if you have installed rewrites, you still need to setup the rewrites so that they know how to process things. Here is a sample config for IIS: https://github.com/getgrav/grav/blob/develop/webserver-configs/web.config

Also if you continue to have problems then check this: https://learn.getgrav.org/troubleshooting/page-not-found

Thanks rhuk.

I appear to have the web.config in place and it has the same values as https://github.com/getgrav/grav/blob/develop/webserver-configs/web.config

Do i need to modify this config?

Thanks in advance.

Really struggling with this one! I’ve come over from a ASP.NET / IIS background and really could do with some advice on how to get the rewrite to work. I can’t see much info relating to IIS configuration.

I’m afraid being mac-based I have very little experience with IIS. There are some users that do use it and I suggest hoping on or slack channel and ask there?

Hi Rhuk,

I’ve managed to solve it. I hope it’s a permanent fix and i dont find any other related issues!

I moved webserver-configs/web.config to the root of the website. I’ve left it in it’s original location also.

Do you think this will have any adverse effects?

should be fine. It’s the same thing for apache, you just put .htaccess in the root of the site.

I have an error called the Mac error code 43 , when I am trying to install the Grav Core I am getting this error, Any solution regarding the issue will be highly appreciated, As per your issue, that might be an issue with the website, try after some time and try to reinstall the browser if the website is blocked or not.