Using GRAV on IIS webserver

Is it possible to have a web.config file to be able to set up GRAV on a hosted IIS webserver? I am trying to use GRAV on IIS and have read the but could not overcome the errors. The explanation in GRAV tutorial is not enough clear.

I’m not really that well versed with IIS, but there already is a user provided web.config file in the root of Grav:

Disclaimer: I know very very little about IIS. I’m not sure what this does, but a Grav site that I made was deployed on a Windows box and the guy that did it sent me this…

Run @ command line, “icacls C:\inetpub\wwwroot /grant IUSR:(OI)(CI)(M)”

Thank you! None of them worked. I am using shred hosting for GRAV. for IIS after I used the web.config proposed by rhukkster, I got the GRAV up but with some errors GRAV on IIS .
I moved to an Apache server, here we get this error

Parse error: syntax error, unexpected T_STRING in /home/statira/public_html/grav/index.php on line 2

By the way I failed to set up GRAV v0.9.37 on shared hosting! Any suggestion!

On local machine (Windows 8.1) using EasyPhp everything is fine! I am taking about web server on shared hosting (both IIS and Apache)

Regarding shared hosting with Apache server, ensure your on PHP 5.4+.

Quite a few hosting providers still default to PHP 5.3 although they do provide ways to switch to PHP 5.4 and higher.

BTW, every shared hosting I’ve tried so far has had no problems running Grav. Some require a little tweaking as they often don’t have PHP at the correct version or the PHP in the terminal setup incorrectly. Check out the docs for examples


Concerning IIS, your error messages are due to missing write directory permissions. I had the same and fixed them by setting the permissions with Plesk (the system that my provider uses to manage the hosting).


On IIS the PHP version is 5.4.32
On Apache the PHP version is

Is it possible to have an install.php to do the job?

I am using Grav on IIS without any issues so far but I am hosting in Azure and running locally using WebMatrix. I have not installed Grav on my own IIS 7.5 server but the Azure hosting is IIS. Have a look at my tutorial, it might help:

I just found out why it has been so easy for me, the skeletons I used had a web.config file. If you look at the “Deliver” skeleton, you will find a web.config file. Some of the skeletons don’t have one, I just assumed they all did.

They should all have them as that is part of the Grav base package.

I looked at some of the skeletons I have in my downloads folder Sora Article was the one missing the web.config.

I just downloaded latest Sora Skeleton. web.config is in there.

@mikegcox, thank you. I have no problem on localhost, but both on Apache and IIS servers (shared hosts) I cannot run GRAV.

Your previous error was related to permissions. I suggest you review this page in the docs on permissions related issues

Thank you! I finally were successful to setup GRAV on Apache server, shared hosting. Still there are few errors, you can see my first trials on
This is a Persian site (RTL) based on deliver skeleton!