Whoops PHP error on install

I’m getting this error after installing and navigating to the URL where I’m hosting my blog. I’ve got PHP 5.4 and Apache - not sure what’s happening (I’m a front-end guy, this is a strange land for me).

xcache_isset(): XCache var cache was not initialized properly. Check php log for actual reason.

Then, underneath:

}

/**
 * {@inheritdoc}
 */
protected function doContains($id)
{
    return xcache_isset($id);
}

Any idea what’s happening and how I can fix it?

Thanks!

It looks like your hosting provider has PHP xcache installed but its not properly enabled for your account. As Grav tries to use the best option available, it’s picking xcache as its installed, but obviously running into problems caused by a bad setup.

You have two options, the first being the easiest solution:

  1. Change the cache driver in user/config/system.yaml from auto to file

  2. Ask your hosting provider to fix the problems with xcache setup.

I would try 1) to get things running, but using xcache will improve performance (probably) so it might well be worth getting that issue resolved with your provider.

Thanks so much for the prompt reply! I’m emailing my host provider now… It’s laughing squid, by the way, in case any other users run into this problem in the future.

We don’t have laughing squid specific instructions, but we have a three hosting provider writeups with detailed information on setup in the docs:

http://learn.getgrav.org/hosting

You might find some handy stuff in those too.

Just to give more info to any who might find it, I emailed with laughing squid support and they pointed me here: http://www.rackspace.com/knowledge_center/article/cloud-sites-php-op-code-cache.

They implement a cache that’s based on xcache, but xcache is not enabled (or enable-able, if I’m reading it right).

I’ll try changing the cache driver.