Weird .md naming after enabling language support

Hi everyone !

I’m coding a website that need to be both in french and english.
I’ve enabled the two langages in my system config, and set french as default.
I then tried to create a new page in the admin panel, and once saved as french, I tried to save is as an english page directly from admin panel.

But then the article page in the admin panel was empty as it couldn’t find the new page. When I wen to check directly to the files themselves, I found out that instead of creating “” and “”, it created for the english version an md file named “”, and I can figure out why.

Any idea ? : /

1 Like

@edi0th, See if your issue resembles this issue on Github: Extra `.md` inserted in filename when creating a new page in admin panel · Issue #3582 · getgrav/grav · GitHub

Unfortunately, no solution yet.

1 Like

Ok thanks ! I’ll be patient then : )

1 Like

@edi0th, Are you still experiencing the same issue? The user who created the issue on Github can’t reproduce the issue anymore…

Hi, I can reproduce it. But only once a day it seems. Not sure why. Could be cache or plugin related.


Are there any processing running at night that might change the Grav installation?

Would you mind investing a little bit of time and try the following:

  • Logoff from Admin.
  • Login into Admin and try creating a new page as you did before.
  • If it does not reproduce the issue, try:
    • Logoff from Admin
    • Clear the cache $ bin/grav cache
    • Login to Admin and try creating a new page as you did before.

If still not reproducible each and every time, I have no other suggestions but to share your experiences at the afore mentioned Github issue.

@AquaL1te, @edi0th,

Please join the issue on Github and share your experiences. The dev team does not read this forum.

The issue is being closed right now because the original poster cannot reproduce the issue. When other users share their experiences the issue should be opened again.

@edi0th, @AquaL1te, I’ve created a new issue in the Admin repo with a reproducible case.

Please follow that issue to track the progress.

@edi0th, @AquaL1te, Bug has been fixed in Grav core. Will need to wait until new release of Grav is available.

1 Like