Weird Grav + caddy + iOS + https problem

I have been running Caddy for a while now, and I’m currently running 0.10.2 version. I am serving a number of sites, local flat files, php, proxied - and all except one are working perfectly.

The exception is running Grav. This is almost perfect as well (leaving aside that the site contents are in an early stage of development). It works everywhere except on iOS when using https. It’s fine on Windows or Android, using any browser, It’s fine on iOS if I am only serving http without any automatic https. But if I am serving https it fails - but only on iOS, with any browser.

In this case it simply hangs, and eventually iOS says the server stopped responding. If I look at the Caddy log, it just shows the initial request, and no other - but this request is repeating. If I try to trace the packets, I see a request from iOS, then a response from Caddy, then a little later a repeat of the same. I can’t read the packets because - well, https, right?

I am at a loss what to try next. Any suggestions?


Hi Paul, I use caddy all the time locally, and I never noticed issues.

Does it happen with a single device or you tried many? Latest iOS?

Does the same happen if serving from localhost using ngrok over https, or just on the remote web server?

This happens with iPhone 5S, iPhone SE, and iPad Air, all using the latest version of iOS (actually, I’ve not tested with iOS 9 on my wife’s older iPhone 4S phone - something to do). My Caddy server is local, not remote; I get the problem within my own network, or accessing it remotely (ngrok looks interesting though - thanks for the pointer).
What I haven’t specified is that I am running Caddy on Windows Server 2012, and that I have IPv6 on my network (though I’ve shown that’s not the issue here). PHP is v5.6.27.
I have reinstalled both Grav and Caddy, and another Caddy+Grav user has checked my config - but I don’t get the problem accessing his installation!

I tried a local Caddy setup with my SE and latest iOS, I don’t get any issue. The only difference I see is I’m using OSX, but I’m afraid I don’t have a suggestion ready on what could be the root cause of the problem.