Local Server Connection Issues

So this morning when I tried using my Local Webserver with grav, I was hit with all sorts of connection issues. This is after about a week running 3 different Grav sites on this server without issue. There were no updates and everything was working last night before I logged off.

I went through the troubleshooting page online, and Curl, OpenSSL support is enabled. I ran through setting all permissions again. I still had issues with the gpm not being able to connect and anything in the admin panel that made a call out to grav failed and everything was very slow loading. If I shut the internet down the grav admin works fine to work in as long as I don’t do anything requiring a connection. After taking a break from it for while, I came back to it all working again.

Now a few hours later I am getting the same issues with anything connecting to the grav server erroring out. When trying to update or install with gpm, it returns download errors.

I have had no issues yet with the online installs of Grav CMS and am at a loss as to why it behaves differently on a local server as to being online.

Is anybody else experiencing these weird issues using Grav CMS on a local server?

Is there something better to use offline for Grav development or testing other than Lamp install?

Any suggestions what I might check to try and resolve these issues?

Thank you.

Maybe try configuration -> system -> advanced

Remote Fetch Method: Auto/fopen/Curl
Official GPM Only Yes/No
Remote Verify Peer (SSL) Yes/No


I switched the settings to:
Remote Fetch Method: AutofopencURL
Remote Verify Peer (SSL) No

add it seems to be running better now. My News Feed and Notifications are back and so far not error warnings.

Thank you.