Typing subpages with forced SSL redirect end up 404’ing (htaccess issue?)

I’m using the following in my .htaccess to force SSL:

# Redirect to HTTPS
RewriteCond %{HTTP:X-Forwarded-Proto} !https
RewriteRule ^(.*)$ https://%{HTTP_HOST}/$1 [R=301,L]
## End - Index

However, I’m running into an issue with subpages. For example,

example.com” --> "https://www.example.com"
without issue, but any subpage like typing

example.com/about-us” --> 404 "https://www.example.com/index.php"
This is even the case for straight www URLs without the “https”, which is why I assume it may have to do with how I’m handling the redirects.

I’m admittedly not that well versed with the .htaccess file, but does this seem like something to do with that or something to do with my certificates or other grav-level settings? Thanks in advance!

1 Like

Grav has an option to force SSL in Configuration > System

That might solve your problem!

Make sure you put this SSL rewrite ABOVE the regular Grav rewrite for index.php

I tried to put above Grav rewrite and it worked! Thanks :grinning: