How to force https


to force http to https I’ve used inside .htaccess
#Force non-www:
RewriteEngine on
RewriteCond %{HTTP_HOST} ^ [NC]
RewriteRule ^(.)$ [L,R=301] RewriteEngine On RewriteCond %{HTTPS} !on RewriteCond %{REQUEST_URI} !^/[0-9]+\..+\.cpaneldcv
RewriteCond %{REQUEST_URI} !^/.well-known/pki-validation/[A-F0-9]{32}.txt(?:\ Comodo\ DCV)?$
RewriteRule (.
) https://%{HTTP_HOST}%{REQUEST_URI}

The problem is that /index.php doesn’t seem to work

I’ve noticed that also doesn’t work

How can I solve the problem?


Hi! In grav the file “index.php” is not accessible (since a routing system is used).

To force the use of https, you have to edit the following file:
user -> config -> system.yaml
And edit line 6:
force_ssl: true

No extra changes are required in the .htaccess :slight_smile:

1 Like

If I’ve understood I’ve to add force_ssl: true in the pages: “area”


No, sorry, I mean the config file:

In the administration panel you can access the configuration in:
Configuration -> Advanced -> Remote Peer Verification (SSL)

The settings are global for the entire site.

1 Like

Have I also to set Force SSL YES?