Force ssl broke grav


When I try to Force ssl in configuration system advanced, I have an error :
“fetch failed, network error …”
after I have a blank page that says “The cause of this problem can be the deactivation or refusal of cookies”

My firefox isn’t configured to refuse cookies, my adblockers are disabled for my Grav install

My install is done on my hosting on a subfolder of my own site, I want to make test Grav to a friend before he buy an host and do it on his host

Does Grav allow to be installed on a subfolder ?, because I’d like to do multiple install on my host to show variants for pages contents and CSS

Thanks for your answers

I’ve my site back :sweat_smile:

I changed my /use/config/system.yaml --> force_ssl to false

I would first test (if you haven’t done yet) if the subfolder and subdomain is set to accept https:// - as such did you test that your subdomain is running as ? Even without grav installed?

That’s the first step. If that works it means it’s a Grav site setup related issue…

Thanks for your answer :slight_smile:

my domain is configured to force redirect to https with an htaccess file on root of domain

RewriteEngine On
RewriteCond %{HTTP:HTTPS} !on
RewriteRule (.) https://%{SERVER_NAME}/$1 [QSA,L,R=301]*
Options -Indexes
<Files .htaccess>
order allow,deny
deny from all

My grav install is in a subfolder and not a sub domain


I looked after htaccess from Grav install and some lines looks like useful to test :

RewriteBase /

RewriteCond %{HTTP:X-Forwarded-Proto} https

RewriteRule .* - [E=HTTPS:on]

End - X-Forwarded-Proto

may I use them ?