Turning off caching messed up the site

I’ve been working on tweaking my site and sometimes it seems that my changes aren’t being reflected when I refresh the page. So I went in and turned off all the caching and when I called up the site again – I get only the name of the site at the top and a message that says, “Page not found”. So then I manually type the path name next to the domain name in the browser and it comes back.

So to reverse the config, I go back into the admin area and all the caching options have apparently disappeared.

I’m guessing that I’ll have to go in and change the caching settings manually to get it back to what it was before… (which is the .yaml config file?)

But I can’t understand why the site wont run right anymore.