Subdomain installation

Hallo,

I have a problem with a installation? There is a folder named: grav-admin on the server. The path:

www.nowa.domain.com/nowa/grav-admin

(there is the main istallation on the domian, in the public_html, so I don’t want to move files and created folder named “nowa”)

  • php 7.4
  • apache
  • grav-admin-v1.6.26

I changed .htaccess:

RewriteEngine on
RewriteCond %{HTTP_HOST} ^sub.domain.com
RewriteRule ^(.*)$ /subdomains/sub/$1 [L,NC,QSA]

now I have this inforamtion:
‘mbstring’ extension is not loaded. This is required for Grav to run correctly

I can’t start the installation. I checked. On the local unziped files, there is a .htaccess.
Can you help?

Regards

the error message indicates that your php installation does not have the extension mbstring enabled/installed, which is required for grav to run.
this has nothing to do with (sub)domains or .htaccess.
you should install mbstring or ask your provider to do so.
HTH

Hello,

admin write, this option is on and it was.
Now I have:

Not Found

The requested URL was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

.htaccess

RewriteEngine On

Begin RewriteBase

If you are getting 500 or 404 errors on subpages, you may have to uncomment the RewriteBase entry

You should change the ‘/’ to your appropriate subfolder. For example if you have

your Grav install at the root of your site ‘/’ should work, else it might be something

along the lines of: RewriteBase /<your_sub_folder>

RewriteBase /

End - RewriteBase

Begin - X-Forwarded-Proto

In some hosted or load balanced environments, SSL negotiation happens upstream.

In order for Grav to recognize the connection as secure, you need to uncomment

the following lines.

RewriteCond %{HTTP:X-Forwarded-Proto} https

RewriteRule .* - [E=HTTPS:on]

End - X-Forwarded-Proto

Begin - Exploits

If you experience problems on your site block out the operations listed below

This attempts to block the most common type of exploit attempts to Grav

Block out any script trying to base64_encode data within the URL.

RewriteCond %{QUERY_STRING} base64_encode[^(]([^)]) [OR]

Block out any script that includes a tag in URL.

RewriteCond %{QUERY_STRING} (<|%3C)([^s]s)+cript.(>|%3E) [NC,OR]

Block out any script trying to set a PHP GLOBALS variable via URL.

RewriteCond %{QUERY_STRING} GLOBALS(=|[|%[0-9A-Z]{0,2}) [OR]

Block out any script trying to modify a _REQUEST variable via URL.

RewriteCond %{QUERY_STRING} _REQUEST(=|[|%[0-9A-Z]{0,2})

Return 403 Forbidden header and show the content of the root homepage

RewriteRule .* index.php [F]

End - Exploits

Begin - Index

If the requested path and file is not /index.php and the request

has not already been internally rewritten to the index.php script

RewriteCond %{REQUEST_URI} !^/index.php

and the requested path and file doesn’t directly match a physical file

RewriteCond %{REQUEST_FILENAME} !-f

and the requested path and file doesn’t directly match a physical folder

RewriteCond %{REQUEST_FILENAME} !-d

internally rewrite the request to the index.php script

RewriteRule .* index.php [L]

End - Index

Begin - Security

Block all direct access for these folders

RewriteRule ^(.git|cache|bin|logs|backup|webserver-configs|tests)/(.*) error [F]

Block access to specific file types for these system folders

RewriteRule ^(system|vendor)/(.*).(txt|xml|md|html|yaml|yml|php|pl|py|cgi|twig|sh|bat)$ error [F]

Block access to specific file types for these user folders

RewriteRule ^(user)/(.*).(txt|md|yaml|yml|php|pl|py|cgi|twig|sh|bat)$ error [F]

Block all direct access to .md files:

RewriteRule .md$ error [F]

Block all direct access to files and folders beginning with a dot

RewriteRule (^|/).(?!well-known) - [F]

Block access to specific files in the root folder

RewriteRule ^(LICENSE.txt|composer.lock|composer.json|.htaccess)$ error [F]

End - Security

Begin - Prevent Browsing and Set Default Resources

Options -Indexes
DirectoryIndex index.php index.html index.htm

End - Prevent Browsing and Set Default Resources

How to solve this case? Is it with Nginx problem?
Regards

is your webserver apache or nginx ?
if nginx, you will have to convert your .htaccess rewrite rules to nginx rules.
maybe this is the problem.

Hello,
yes there is sth wrong with it. I hope.
I tried to do the installation on the other hosting. The only what I do is: AddHandler php72-fastcgi .php You know why.

The effect:

Hello,
it looks like apache
https://docs.cpanel.net/cpanel/

Maybe this is a problem with subdomain and subfolder?

Regards