Slug of none english title

Hi guys,

Firstly so thanks for this great software.

I use grav for a Turkish site.

My issue is that;

When i create a page with title üzüm

Grav creates slug as uezuem

How can i fix this?

Thank you so much.

Hello and welcome @ufukayyildiz

If you see Grav Documentation on this link
1. Multi Language Routing:

You will se the french example of the slug usage: the example omits the french accented letter, I quote:

---
title: Mammifères
slug: mammiferes
---

2.- In the Configuration section you have the possibility to define a list of special_chars: to automatically convert to entities. I would suggest to try, but use it with caution, it might affect how templates or script behaves, depending on the character converted. The developers will have a better response than mine. Hope this can help:

The Pages section of the system/config/system.yaml file is where you set a lot of the main theme-related settings. For example, this is where you set the theme used to render the site, page ordering, twig and markdown processing defaults, and more. This is where most of the decisions that affect the way your pages are rendered are made. …

special_chars: List of special characters to automatically convert to entities. Each character consumes a line below this variable. Example: `’>’: ‘gt’

Regards.

1 Like

thank you. I will try this.