Strange behaviour of language switcher not picking up language specific slug

Hi everyone,

I’m developing a site which has English (as the default language) and French.
I’ve followed the doc to install and setup multi language feature.
I’ve created my pages in English, then did the translation. All the files seems fine and the site is running well.
But I realized a small issue with language switcher.
I have a page in English called “aquisition” which is also its slug:
Which is fine since I do not want the default language in the URL.
When I check the link of that page in the “fr” link of the language switcher, I see instead of (the spelling is slightly different in french).
But then all menu item when in French are correct. In the menu I see which is fine.

Am I missing a setting some where. I’ve read a lot and search a lot but aside from a github
issue saying that it’s not possible; I haven’t been able to figure this one out.

Thank you in advance.

Have you set the ‘slug’ in the french page? Like:

title: Acquisition
slug: acquisition

And in /user/config/system.yaml:

  redirect_default_route: true

Thanks pamtbaau,

I had set the slug properly but I guess I’ve trying different settings and could not make it work.
Though, I realized that the actual link of the “fr” version is pointing at the english slug of the page but with /fr/ prepended. And when you click, it redirect to the correct slug.
This is where grav’s magic is happening !

So all good on my side.

We can close that one as “Solved”.

Thanks again for your very quick help.