Site Crash after Grav Update - short story

so, yesterday I decided to try an Update to grav 1.7 on a local docker clone of my website.
update was done via cli - gpm and directly gave me this at the moment the cache would have been cleared:

In AbstractFile.php line 417:
Provided data is not a string  
cache [--invalidate] [--purge] [--all] [--assets-only] [--images-only] [--cache-only]

I could then still log into the admin and saw the update had happened, but the site itself crashes (crikey)
and the log gives this:

Grav System Log Output
Display the 20 most recent entries...
Date 	Level 	Message
January 21st at 2:36pm 	CRITICAL 	Provided data is not a string

I then checked with grav yamllinter to be sure the are no syntax errors anywhere and received this:

Yaml Linter
User Configuration
[OK] No YAML Linting issues with configuration                                                                         
Pages Frontmatter
[OK] No YAML Linting issues with pages                                                                                 
Page Blueprints
[OK] No YAML Linting issues with blueprints                                                                            

I also switched theme (3 installed) to no change.
same after a new update from today to grav v 1.7.1

then I decided to deactivate all plugins one by one and voila:
after deactivating my own plugin ipcount, everything else worked again :smiley:

so, I’ll have to fix this…

this little story is here to just show what can go wrong and eventually how to troubleshoot - have fun :innocent:

1 Like

so, I found the reason for the crash: Grav 1.7 obviously requires a type cast when storing numeric data to a text file - issue solved :smiley: