Latest update triggered sitewide failure...?

Surely I must be doing something wrong.

I run two sites. One upgraded fine. The other when I tried to upgrade failed, revealing a site that looked like this:


I tried nuking the site completely and reloading from my latest backup (about a week ago).

Three plugins all updated fine.

Then when I updated the core, same kablooey.

It’s related to Gzip. Seems your server has it turned on, but Grav does not have it enabled. You can enable it via user/config/system.yaml:

  gzip: true

We made a change to the default encoding that should actually fix things, but it appears to have made things worse.

BTW, before you ‘fix’ this, do you happen to know the server configuration that is causing this. I can’t replicate even when i force gzip via mod_deflate and .htaccess

I will back-rev my system and then do a configuration dump for you. Will that give you the information you need?

well i don’t know how to replicate it, but i know the issue. I’m working on a fix that reverts the previous behavior but allows the use of identity for those that need/want that.

I changed the GZIP line to true and everything now seems to be as happy as a Happy-Bot 9000.

Thank you kindly for your patience!