Severe error, any clue where it comes from?

I have uploaded a grav based documentation (latest learn2) with custom contents and I get a very strange phenomenon: If I open it with my default firefox all goes well and smoothly but when accessing it with Chrome it just shows a bunch of characters as you can see from the attachment. If in Chrome I press Ctrl+F5 the page loads up exactly how it should be loading but after this forced refresh if I hit again a simple F5 the problem comes back. Have deleted all files from cache and assets directories and disabled caching but the error is still there. You can see it for yourself at

The site locally functioned perfectly. Downloaded and tested and it is ok. So it remains to be a server bug? How could the server cause this, any clue what can be done against it?

where the files created/saved as UTF8?

Yes, they are UTF8.

Could it be a file corruption issue? Try uploading a zip file to the server and then unzip the files one the server (maybe you already did that, but I try)

Tried on another server with same php version and is working as expected. I uploaded it at the first time too via a zip, tried it again, still the same thing happens.
In the cache folder I see a file with 0 bytes with the filename problem-check-g-d4aa3331.
In the assets folder there is a file called bad250a5b03bc912f3d2d55ac4e30e48.css that isn’t empty, has css code inside.

The problem-check-... file is normal, just an empty file to know that we’ve checked for problems. The file in your assets folder is probably the compressed file of your css created because you have pipeline turned on.

Sounds like a server setup issue somehow. It’s weird though because I’ve never seen that.

to the logs nothing is being written out after these weird page loads.

Well seems to be a reason to advise for migration to a different host.

I see this as a server configuration issue but still I guess there is something in the newer grav version that causes this error to appear. There is another grav site on this server that works without any problem but this new site for the documentation has the latest grav system in it. The old grav sites version is 1.0.0-rc.2 while the newer is 1.0.8. Both servers run on PHP 5.5.

I can’t think of anything that has changed that would cause this. You can easily test though. You can download the Grav 1.0.0-rc.2 package from the GitHub releases, and then copy your user/ folder from the site with the problem into it. That will recreate the site under that older version of Grav. Everything that makes a Grav site is contained within the user folder.

:d it works nicely with this older version. Even the navigation with keyboard is ok which wasn’t with a grav version in between.

Think I got at least the pattern what makes it run ok and why it doesn’t: First I moved the documentation into a wiki folder that had before a different site in there. Afterward into a new folder called learn but without emptying the cache for the very first run. On FireFox I didn’t see anything going wrong as the crashes are observed under Chrome. So this made some caching server errors that persistently caused the site to crash. If I created a folder with a name that hasn’t been used and made sure that the cache folder is empty for the very first run this method assured for both the older and newer version of grav to work without crashing.

No I do not understand it. For the time I wrote the previous post the page was working in chrome now just no grav site is working, neither the old one that was working before. The main site is in grav at and its down with error 500. The subpages like phpbb with other systems are working.

Now all works again, the magic: Cleared the caches, cleared all caches etc. from chrome, first loaded the page with chrome. Hope this time it will last.