[RuntimeException] error while trying to download (admin plugin)

Hi people! Just arriving to Grav, and when finally I was installed on my QNAP, everything starts fine, until I tried to install the admin plugin.“bin/gpm install admin”

and shows

[RuntimeException] Error while trying to download ‘https://github/getgrav/grav-plugin-form/zipball/0.6.0

It’s me, or the URL was bad? Anyone can help me, pls? Thank you in advance!

Hi @Paco it’s the URL most probably,it has something to do with missing releases, see here https://github.com/getgrav/grav-plugin-form/releases. However you may try to install it manually (copy and paste) till this issue is fixed.

I had same problem, I opened my php.ini file and uncommented this line:


It worked for me

Finally, I installed manually all the associated plugins to Admin (Form, Email, …), but may be I’m doing something bad, because when points the URL to the Admin plugin (mygrav.com/admin) it doesn’t works :’(

If your getting a 404, then it’s probably a page routing issue that you need to fix on your server. Check out the docs for more information on 404 Errors and how to fix.

I revised the probably issues of the 404 error, but it’s seems all it’s ok. May be I don’t understand how the Admin plugin works :

  1. Points the URL to http://192.168.0.xx/admin (remember, I installed Grav on my QNAP NAS)
  2. 404 error shows The requested URL /share/MD0_DATA/Qweb/grav-skeleton/index.php was not found on this server. Of course, I changed the default ReWriteBase from / to /share/MD0_DATA/Qweb/grav-skeleton/ in the .htaccess file

It seems that Grav lookings for index.php on that directory, and shows was not found, but it’s there ! ¿¿??

Yeeeeeeeeeeeeeep do it! It was my fault, the issue was on the path for the URL, just changed from /share/MD0DATA/Qweb/grav-skeleton/ to /grav-skeleton/ and wow!, the Admin screen appears! Thank you mates, and sorry #Gravbeginner :stuck_out_tongue: