Running Grav build-in webserver: "No such file or directory"

I’m at Step 3 of installing the Grav Server:

Now you can navigate to the root of your Grav installation in your terminal and then run:

bin/grav server

So I run this in the terminal, and I get:

[david@mycomputer bin]$ bin/grav server
bash: bin/grav: No such file or directory

What am I doing wrong?

@dpdoug, Looking at your shell prompt [david@mycomputer bin]$ bin/grav server, did you perhaps cd into folder /bin inside the root of Grav? In that case bin/grav does not exist. You’ll have to cd into the root of Grav.

Thanks, that worked!

I ran http://localhost:8000 and it gave me a list of all the modules it checked out. there is one that it had problems with:

PHP GD (Image Manipulation Library) is required but not installed

where do I find this to install it?

Also it says:

Apache Modules: Apache not installed, skipping...

Is Apache required for it to work? If so, where is the best place to install it. I’ve installed it before, but maybe it just needs to be started.

@dpdoug, Please do not use an existing and solved post for a new question. Please create a new post with a proper title.