Remove query strings from static resources

I have my website zipping along really nicely and it’s fast…super fast. But I would love to get it to lightning fast.

Enabled Cloudflare and I’ve enabled advanced-pagecache, precache, staticfilecache and twigcache and also ramped up the browser caching by adding the following to my .htaccess

<IfModule mod_expires.c>
ExpiresActive On
ExpiresByType image/jpg "access 1 year"
ExpiresByType image/jpeg "access 1 year"
ExpiresByType image/gif "access 1 year"
ExpiresByType image/png "access 1 year"
ExpiresByType text/css "access 1 month"
ExpiresByType text/html "access 1 month"
ExpiresByType application/pdf "access 1 month"
ExpiresByType text/x-javascript "access 1 month"
ExpiresByType application/x-shockwave-flash "access 1 month"
ExpiresByType image/x-icon "access 1 year"
ExpiresDefault "access 1 month"

The only thing holding it back seems to be this element in [Pingdom]( and [Google Page Insights](

*Remove query strings from static resources* - Pingdom and 
*Eliminate render-blocking JavaScript and CSS in above-the-fold content* - Google

Is there an option to do this in Grav or will I need to do something with htaccess or another type of plugin?

BTW, advanced page-cache kinda kills the need for precache, staticfilecache, and even twigcache. It’s just caching the whole page output.

There are two options in the system config:

  enable_asset_timestamp: false

  enable_media_timestamp: false

These are off by default, but if you have enabled either of these, they will cause the ?3893930920 type stuff at the end of the items.

Note: turning this off will mean your CDN and even the browser doesn’t know if an asset has changed, and while it makes it faster, it makes it very hard to get any content changes to your end users

Awesome - will give this a go and see what happens. Cheers!