Problem using gpm

Hi there, I’m trying to install a plugin using GPM. First I got an error that it required php. I run LAMPP, so that seemed strange to me, but maybe it’s an environment variable setting somewhere? When I simply installed php using apt-get (ubuntu) it said “GPM requires PHP Curl module to be installed”. I can try to activate Curl, but I’m getting the feeling that I’m doing it wrong and that it should be using the php installation in LAMPP.

Hi Oscar, you mean XAMPP? Anyway, PHP might not be in the terminal path. See for example

Yes, xampp for linux, I thought that was called lampp :smiley: I fixed it now by installing php and php-curl packages with apt-get system wide, but it feels like a dirty fix. Furthermore, I now have an apache server running on startup that I need to manually turn off every time I want to start up xampp. I found that post you sent me but that didn’t solve it for me at first. When I run “which php” it tells me that it’s using “/usr/bin/php” even though I added “/opt/lampp/bin” to the path variable. Do you think I should uninstall the new php installation?

Ah never heard of LAMPP :slight_smile: If you don’t need the built-in PHP and it’s just confusing, you can just use the LAMPP version. Same goes for Apache. I think /usr/bin comes before /opt/lampp/bin so it has precedence over the lampp PHP binary.

Ah right. Well I’ll just use this for now, it’s a test environment anyway. Thanks for the quick response!

Yah same for me, i’ve never run anything but the native packages for a linux environment. It’s not dirty, apt-get is how you should be installing stuff, as those are the officially supported packages, any 3rd party LAMP stack on top of linux sounds dirty to me :slight_smile: