Page.summary === doesn't work after updated 1.3.3


#1

Hi, I found myself in trouble.

My environment is DBCS, Japanese. charset is utf-8.
I always put === wherever I want to truncate, with blank linPreformatted textes above and down the delimiter. The summary size is variable.

Since I’d installed the newest version 1.3.3, the delimiter === hasn’t been working.

my post is

<p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec ultricies tristique nulla et mattis. </p>

[plugin:youtube](......)

<p>Phasellus id massa eget nisl congue blandit sit amet id ligula. Praesent et nulla eu augue tempus sagittis. </p>

===

<p>Mauris faucibus nibh et nibh cursus in vestibulum sapien egestas. Curabitur ut lectus tortor. Sed ipsum eros, egestas ut eleifend non, elementum vitae eros. Mauris felis diam, pellentesque vel lacinia ac, dictum a nunc. Mauris mattis nunc sed mi sagittis et facilisis tortor volutpat. Etiam tincidunt urna mattis erat placerat placerat ac eu tellus.</p>

Then, the Grav shows

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec ultricies tristique nulla et mattis. Phasellus id massa eget nisl congue blandit sit amet id…

This is not what I want.
Would anyone give me any advice, please?
Thank you.

In site.yaml, I set as follows.
summary:
enabled: true
format: short
size: 0
delimiter: ‘===’

Once I set 300 to size, but nothing has changed.


#2

Pretty sure this is resolved with current develop branch. Will be released as 1.3.4 next week.


#3

Thank you for your reply and let me know it’ll be resolved next week.

I’ll wait for the resolved version.

I love Grav, it’s wonderful cms.
Thank you for your support!