Noob Help

I have grav installed on my new mac in a seemingly working state. However…

When I add a new page I get the error that the page does not exist on the server.

I’ve added a block to my httpd.conf file and the intro Home page displays so I know it works. And when I add an ordered location to ./user/pages/ I see its title or menu attribute shown in the menu bar so I know grav is reading it. I also have the directory and file set to the same ownership and permissions as the 01.home dir and file.

But again, when I click the menu item… the page can not be found on the server.

Any tips, hints or tricks?

I take it your using the built-in apache/php? It could be that you don’t have .htaccess overrides enabled in apache. You probably need to enable:

AllowOverride All

In your default or virtual host.

For a more robust solution, I strongly suggest you follow this guide and install PHP via Brew.

I added this to my httpd.conf file

<Location “/grav”>
Order Deny,Allow
Allow from all
AllowOverride All

but no luck, same behavior

I changed it to a Directory tag and still no luck. And I am pretty sure my httpd.conf is now wide open as well. :\

I guess next is to go through this troubleshooting page, and ensure you have everything ok.

Really the issue is the .htaccess is not being processed, as that handles the URL rewriting to find the child pages.


have you tried MAMP?
On my Mac it works out of the box.