Installs fine, but

Grav 1.0.10 Core/ Mamp Pro 3.5/ Coda 2.5.16/ MOSX 10.11.5/ MBP 15" Retina

Installation is, as documented, as simple as unpacking a zip file into the requisite directory and pointing the browser to it. This went exactly as anticipated. Kudos.

However, I seem to be doing something wrong. Attempting to create Page 2 as per the instructions on the index page, well, fails. I create a folder in /user/pages called 02.page2 and option-drag the .md file from 01.home into it. Change the ‘title’ on the new page. The title shows up as a link on the default page, but clicking on that link returns “Not Found : The requested URL /newpage was not found on this server.”

I’m sure I did something wrong, but can’t find a fix in either the user or general config files.

@snip Did you read and tried ?

Thanks for the tip… and no, htaccess was NOT there. However, it is now, and I enabled the rewrite base several different ways, even including fully-resolved: no joy :frowning:

My attempts (in reverse order):
1: http://Snippe-Grav:8888/user/pages/
2: /user/pages/
3: /pages/
4: pages/

Restarted the server after http://Snippe-Grav:8888/user/pages/, tho that should make no difference, afaik.

It currently looks like this:

RewriteBase /pages/

End - RewriteBase

Most likely you won’t need rewrite base. Try it first with just the bone-stock .htaccess file.

OK… so what I ended up doing to make it work, which it does now, is deleted all the files in the server folder, load the .zip into it, and unpack it. Duplicated the 01.home dir and renamed it 02.copy. THAT worked.

Now to find out why drag’n’drop broke it. I suspect you are right, rhukster: I likely lost and disconfigured the .htaccess. It is there now, as it should be, in the unpack process without any help from me. Lesson learned (maybe.)

Thanks, all. Appreciate the responsiveness here… looking forward to getting slightly beyond newb with Grav. And yes, Sommerregen… I will get better at RTFM :confused: I had, but…