Keep gettin Errors on Subpages

I managed to install GRAV (soraarticle-skeleton) in a subfolder of my webspace and pointed a subdomain to that folder.
The call of the frontpage works perfectly nice (if you ignore the fact, the test-blog-entry-style is totally f***ed up … could not figure that one out by now -.-)
The (current) main-problem is, if i hit “Read more” or any other link in that theme (like “contact”) i get a server-error and nothing more.
I wonder why that can happen, as the theme is completely original (exept the http->https corrections).
The system.xaml is also untouched (but i already tried to change the “alias” to the subdomain, to “/” and the actual subfoldername which all leads to 404-error-pages from the theme.
Have I forgot something important? Oo

Check this not found page out in the grav learn docs. It should help you isolate the problem.

Yes, I found that one. But unfortunately, it did not work.
I have installed Grav in a subfolder (/blog-subfolder) and the subdomain pointing there is a symlink named (thats the way it works on my server).
I already tried to change the RewriteBase to /blog-subfolder but that changed nothing. Frontpage works, anything else does not.
If I put Grav directly in the folder (another possibility but lesser favorable), it works as intented. Exept the still messed up blog-entry xD
Is there some possibility to get it working with the Symlink -> Subfolder construction?

Are you running apache or nginx? did you do anything special to get the version working correctly? Maybe your websever is configured to not allow symlinks? Is AllowOverride enabled (assuming its apache)?

Basically you have a server config issue, it’s not Grav related really. It really all depends on how your server is setup

Yes, its an apache webserver (shared!).

The global .htaccess-configuration starts with
"AllowOverride AuthConfig FileInfo Indexes Limit Options=ExecCGI,Includes,Indexes,MultiViews,SymLinksIfOwnerMatch"

Other websites, such as OwnCloud, Piwigo or osTicket works fine with Symlink-Domains.
With those sites, I just typed at the correct location the normal ln -s /target/directory/ et voila … works :slight_smile:

So there is something differnt between Grav and those examples which permits the symlink subdomain.
I admin this is a very special case to fix and basically it works (when storend in the subdomain folder) … anyways: Whould be great to get it working for the equallity with the other sites ^^

I use symlinks extensively in my development server. Many of which are in a similar configuration to yours, and it all works fine, so i’m not sure what else it could be :frowning:

Perhaps you can send me a zip of your entire site so I can see if i can replicate the issue?

Sure. Send the email to the address providet in GitHub :slight_smile:
Thanks again for your great help.