Cant Navigate to Subpage of Blog post

Please i installed grav using the ‘notepad skeleton’ on apache in ubuntu
the page loads fine and i see the homepage
but when i try to navigate to the blog post of other pages in the skeleton i get a 404 Error page

I have tried uncommenting the htaccess file
I have tried setting file permissions up to 777
made sure that AllowOverride All is enabled in in my /etc/apache2/sites-enabled/000-default.conf

I dont know what else to do or check
My php version is 5.5.9

With uncommenting the htaccess file you mean you renamed it to .htaccess?

Did you check to ensure mod_rewrite and mod_headers are enabled in your apache config?

Thanks a lot enabling rewrite and headers module solved my problem. . . .
Now lets begin skinning Grav, hope i learn something new from using this anyway,
Apart from the Online Doc if there is any useful documentation you would refer me to,
will totally appreciate that

I would recommend looking over the Twig documentation. Start with Twig for Developers:

thanks a lot, it already looks resourceful to me