Install Problems

Hi everyone,
I am trying to install GRAV on Hiawatha, I copied the code
specific to the Hiawatha server and pasted it into my hiawatha.conf file,
just to note there is a small typo in the code from the Developer, one of the lines
of code has a gap between the letters ba t, it should be changed to bat
The code below has been corrected, and is what I am using to try and get GRAV
to install and work on my Hiawatha Server.


UrlToolkit {
ToolkitID = grav
Match base64_encode[^(]([^)]) DenyAccess
Match (<|%3C)([^s]s)+cript.(>|%3E) DenyAccess
Match GLOBALS(=|[|%[0-9A-Z]{0,2}) DenyAccess
Match _REQUEST(=|[|%[0-9A-Z]{0,2}) DenyAccess
Match ^/(.git|cache|bin|logs|backup|webserver-configs)/(.) DenyAccess
Match ^/(system|vendor)/(.).(txt|xml|md|html|yaml|php|pl|py|cgi|twig|sh|bat )$ DenyAccess
#Match ^/(system|vendor)/(.).(txt|xml|md|html|yaml|php|pl|py|cgi|twig|sh|ba t)$ DenyAccess
Match ^/(user)/(.).(txt|md|yaml|php|pl|py|cgi|twig|sh|bat)$ DenyAccess
Match .md$ DenyAccess
Match ^/(LICENSE.txt|composer.lock|composer.json|.htaccess)$ DenyAccess
RequestURI exists Return
Match . Rewrite /index.php

#=============================================END OFF
I uploaded and unzipped the GRAV package titled “” to
my server and placed all the extracted files and folders in a sub-folder on
my server titled explorer, from which I can access html and php pages, so php
is working, I am using FastCGI as follows,
php -v
PHP 5.6.22 (cli) (built: May 26 2016 15:36:45)

Then I typed, cd/…/explorer ,then, bin/grav install , and got the following
ERROR Missing .dependencies file in user/ folder
ERROR invalid YAML in .dependencies

I do not know what this means, so could someone tell me where to find
and how to install these dependencies, are they scripts, or just missing files,
I followed the install procedure from your site, and did not see these
dependencies listed under PHP requirements, so am at a loss.

Any help would be much appreciated

Thank you kindly, john

You got the package from the site, you don’t need to run bin/grav install. Grav should already run.

That command is only needed when cloning / downloading from GitHub.

no matter what I do GRAV will not work, I have installed it in several folders, one at a time, and every time I get Internal Server Error:500.
I’ve installed all the prerequisites, I have also installed phpinfo() scripts
and as I installed memcached instead of memcache, I uploaded a script to show that memcached is working and data is present in the cache, all these scripts
are in the exact same folder as GRAV, yet GRAV will not pop up when I navigate
to the folder it is in, even if I add the index.php extention in the browser.

I have used and not used the rewrite settings in the hiawatha.conf file that I got
from the Developer of Hiawatha web server, and I get the same error each time.

Any help would be much appreciated.

Thank you kindly, john

I have now pointed Apache to the same install directory and still no GRAV, all
I get is the http500 error, yet all my scripts work from the same directory either under hiawatha or apache.
The only thing I can think of is my download is corrupt in some way, or else the mbstring settings are not correct, I never looked at these setting before and when I see that one of the settings is disabled, I wonder if this is wrong, I will paste the settings below, and if anyone thinks they are wrong, could they explain what file I need to edit to get them right, this is from my phpinfo()

Multibyte Support enabled
Multibyte string engine libmbfl
HTTP input encoding translation disabled << This I worry about?
libmbfl version 1.3.2

mbstring extension makes use of “streamable kanji code filter and converter”, which is distributed under the GNU Lesser General Public License version 2.1.

Multibyte (japanese) regex support enabled << and how is japanese enabled?
Multibyte regex (oniguruma) backtrack check On
Multibyte regex (oniguruma) version 5.9.5

Also, does having memcached installed instead of memcache cause any
problems, I would think you would have to either write your script for one or the other, is this correct, or does php just handle caching with what
ever module is installed.

Any help would be much appreciated

Regards, john

Could probably be a permission issue in the Grav cache/ folder. Check

Tried setting it up but I stumbled on some configuration issue for basic PHP setup, need to try again.

Hi, I will look into permissions again.
I just installed FluxBB which uses a database, into the same folder as
where I tried to install GRAV, and both apache and hiawatha can open
the site no problem.
Perhaps if someone could tell me the files that need extra permissions#
I could do this manually and see if it helps, but as far as I remember I set
all to 775 in a bid to over come this while setting up GRAV and it still did not work.

Finally got it working, went at it in a rather unconventional manner, I changed
the owner and user of the instillation folder to root, and gave 0777 to all files
and folders.
So now I will change the owner, and the permission in a logical manner to determine the correct settings.
Maybe if I had of installed via github or yum then perhaps I could have used the install warnings as a guide to setting file permissions, this would be a very useful
feature to have built in by default, checking the file permissions and outputting
a list of those that are not writeable, and what permission the particular folder
or file actually requires.
If this facility is already included, then a list of the files and permissions would be
of tremendous benefit to static installers like me, who just uploaded the files to
my server.
In any event I have working admin panel, and a user interface.
Still a work in progress, but will report my findings.

Regards, john

I have spent hours adjusting file permissions which only stopped things working.
I have only one error message to deal with now, that is when I do a backup,
I get “internal server error” in a red popup, yet when I look there is a backup zipped file in the backup folder.
I have all permissions 0777 for testing, so there should be no possibility that file permissions are the problem.
Can anyone help with this error.

Thanks, john