I can't check for updates due to peer certificate authentication error

When I log in to my website Administration Panel, I get this error message:

Peer certificate cannot be authenticated with given CA certificates for "https://getgrav.org/blog.atom".

with invalid AJAX response therefore I cannot check for updates both Plug-ins and system.

Same here. Didn’t even update Grav for a while now. It just started happening

Not sure and beyond my expertise, but it could be related to an expiration of a Let’s Encrypt’s CA certificate: Top websites see outages as Let’s Encrypt’s CA certificate expires.

1 Like

OK, so I talked to my sys admin and he confirmed that most have expired root certificates and he advised me to add peer SSL verification to false where request is initiated. So I remembered I saw something about that, but then found this old topic. Then I found this setting is in /config/system.yaml, so in Admin went to Configuration > System > Advanced and have set Remote Verify Peer (SSL) to No

Now it works as expected (Grav news, plugins updates)
I suppose until every website fixes root certificates, will have to live with this option off


Thank you for your advice, it helps me to solve my problem.

Interestingly, while setting this option fixed the SLL errors I was receiving and allowed me to once again get downloads, my news section isn’t updating. Everything in there still 7mo+ old.

Ive been trying for a day and a half to find why I cant connect to grav gpm etc via bash or through the localhost. Your answer finally solved my problem. The SSL warning notifications are therefore very important and this setting needs to be changed. THANKS!