Invalid AJAX response

Can’t upgrade my new install of a grav skeleton because of “Invalid AJAX response.” also this pops up then: “Error while trying to download (code: 0): Message: URL using bad/illegal format or missing URL”
Same with theme installs.
What am I doing wrong?
I’m on Hostens shared hosting.

Did you solve the problem?

This error appears on shared hosting when an IP connection (to grav, github, or amazonAWS…) is blocked. There may be an option in your host’s control panel to unblock all or selected IPs.

Setting the Remote Fetch Method to fopen fixed this in my case:

1 Like

I was receiving this “Invalid AJAX response” issue along with some SSL certification authentication ones (whose messages I unfortunately cannot reproduce). I tried the Remote Fetch Method tweak above with no luck, but, given the SSL issues, I tried setting the Remote Verify Peer (SSL) option to No which worked and allowed me to update to the latest version of Grav.

I actually went back and set it to the default of Yes and the error message never came back. Seems like a bug maybe was introduced to the server new Grav updates resides on that older versions don’t like.

Anyway, I hope this tip might help someone out there. Would like hear from someone from the Grav team perhaps help us understand the issue.