Homepage is error 404

Hey Grav community!

Basically my website worked fine before this. But recently, I tried to set up my website so that it’s multilingual. So I had to create .en.md and the .fr.md files for my two different languages. (.en.md for English and .fr. is just an example of a language) Everything worked out fine, I could load my pages in two different languages. It loaded in www.domain.com/en/etc. (Note that www.domain.com is just an example, not my actual site.)

The problem came along when I searched up my website, and when I clicked the link of my website, which was still as www.domain.com, it showed up as error 404. It used to bring up my homepage, which is the file from my /home folder.

Now in order to get to that page, I have to manually type www.domain.com/en/home. And I have tried to reroute my link to that specific link but in vain. Yeah so everything is working fine except for the fact that I can’t get to open my homepage from the usual link.

So after spending considerable amounts of time on this, I decided that maybe one of you guys have a clue what’s going on? And maybe even better, I can set my www.domain.com link still as my default homepage, without having the /en add on. Please help a newbie out haha. Thanks in advance!

@zisiyan, The settings in ‘/user/config/system.yaml’, should look something like:

  supported:                    # List of supported languages
    - en                        # (1)
    - fr
  include_default_lang: false   # (2)

  alias: '/home'                # (3)

The above says:

Hope this helps…

1 Like

Thank you so much, it worked! Hahah I just needed to add include_default_lang: false, and it worked. You’re a life saver. :slight_smile: