Grav sandbox destination --env

root@devuan1:/var/www/grav/grav-admin# bin/grav sandbox destination --env

Pages Initializing
/var/www/grav/grav-admin/user/pages → Created
mappings: /.gitignore does not exist!
mappings: /.editorconfig does not exist!

What does the absence of these two mappings suggest about my grav install, please?

Note: Linux Devuan, nginx, and ufw are also installed.


A proper post consists of:

  • a title that succinctly and accurately describes the issue,
  • contains a longer, but still succinct, description of the issue,
  • explains what one is trying to achieve and
  • what one has tried.
  • properly formatted snippets containing only relevant information may compliment the question.

Lazily dumping the result of some shell commands without any description does not constitute a proper question. Expecting the reader to dig through the listing does not show much respect for the reader. Show you have invested time in the question before asking multiple readers to invest their time in the question.

Please help the community help you by making it as easy as possible for the reader to understand the issue. This will in turn increase the chance of getting an answer, or even better, the correct answer.

You might consider rephrasing the question…

I was in the middle of editing the post with that info when the Forum algorithm decided to lock the post for some undetermined length of time.

If you will look at my other two requests for help - I tried to be as clear as I could be.

@nginxgrav, Sorry, I have no experience with nginx. You could take a look at this doc at Grav’s documentation: Nginx reads “It is assumed that your Nginx configuration is located in /etc/nginx/ and your Grav installation is stored in /var/www/grav/.”

I chose grav-admin because I wanted the extra features of admin to manage the server implementation of grav.

I asked here and was told that it should be OK that grav-admin is in /var/www/grav/grav-admin rather than /var/www/grav/.

Should the installation instructions say to install grav-admin to /var/www so that that result is /var/www/grav-admin rather than /var/www/grav/grav-admin`?

Or is that not a likely cause of this problem?