Nginx cant find my site

Hi there,
I got a problem with my grav site:
For some reason nginx can’t find my grav project and always returns a #404
Here’s a screenshot:
I’m using multilanguage and it redirects from /grav-admin/ to /grav-admin/en/ but there it just returns 404.
Directly navigating to /grav-admin/admin results in the same error.
This is the debug log: I think it’s caused at line 435. To me it looks like it tries to access /grav-admin/de/ as if it was a folder, resulting in an error… But I dont know how to fix it.
Here’s my nginx.conf:
Can anyone help me please?
Thank you :slight_smile:

How have you configured Nginx for Grav? There is a sample webserver-configs/nginx.conf in the package. Did you use a modified version of that?

I put my nginx.conf in the post above… <_<

you know… getting an answer from ANYONE who at least read my entire post would be really cool… :stuck_out_tongue:
gettting your answer as the only one within 3 days really sucks… :stuck_out_tongue:

Do you get the same problem when using the sample nginx.conf?

It’s kinda hard to debug these kinda things. I’ve installed with Nginx many times. I always use the default nginx configuration with minimal changes for paths etc. And it just works.

The advanced configuration of Nginx is something beyond my skills to help with i’m afraid.

wit hthe default configuration I got “302 - permanently moved” for every file. I now switched from CentOS to Ubuntu Server and now it works. Thanks anyways. :slight_smile: