Grav installation on Azure App Service

I am wanting to deploy the Grav CMS on an Azure App Service. I’ve followed the instructions given, but when attempting to run a Github actin to build and deploy I get the following error.

Your lock file does not contain a compatible set of packages. Please run composer update.

  • Problem 1*
    • getgrav/image is locked to version v3.0.0 and an update of this package was not requested.*
    • getgrav/image v3.0.0 requires ext-gd * → it is missing from your system. Install or enable PHP’s gd extension.*

To enable extensions, verify that they are enabled in your .ini files:

    • C:\tools\php\php.ini*
      You can also run php --ini in a terminal to see which files are used by PHP in CLI mode.
      Alternatively, you can run Composer with --ignore-platform-req=ext-gd to temporarily ignore these required extensions.

I’ve tried creating a new settings.ini file on the App Service that sets the PHP’s gd extension, but that does not solve the issue. I am not very familiar with PHP and was hoping I could get some guidance on how to solve this please

Quick update. I’ve managed to install Grav on Azure. I reverted to manually uploading the site to the App Service. I followed the instructions on to make changes to the .ini config file . Ref: Configure PHP apps - Azure App Service | Microsoft Docs. Grav admin site is running now.