Grav Admin permission issues on CWP


We’ve been running Grav successfully on Plesk with CentOS7 for some time now but recently installed Grav on CWP also with CentOS7 and have now some issues with the Grav Admin permissions.

All menu items work except if we try to access the Configuration and Pages menus, then we are faced with this error message: “You have insufficient permissions for task dashboard.” and a new Login Page.

No matter what we try we cannot login to those pages.
If we simply go back with the Browser then all other pages work as normal, but still not the Configuration and Pages menus.

When I click Logout there are some error messages in the top rh side that show:
unauthorized and Fetch Failed.

Any advice please, also some advice on the correct folder and file permissions.


OK everyone,

The problem was that I had this same site in my browser cache with different user details and cookies. When accessing from another browser it worked so I simply cleared all browser cache and cookies and now fine.

1 Like

There are still a few permission issues it seems.

I get this from time to time while logged in as Admin
You don’t have permission to access /admin/gantry/configurations/1_home_page/layout/particle/showcase-6764.json on this server.

Looks like it might be a Mod_Security issue.