Grav 1.7 curl - PHP Curl in local host - Wamp

Good morning,
I’m trying to update grav to the latest version. I have a local copy in the pc with WAMP and PHP 7.4.16 with the extension curl activated.

As I understand, for some reason, Grav send me this error: Use of undefined constant CURLOPT_CAINFO - assumed 'CURLOPT_CAINFO' (this will throw an Error in a future version of PHP)
Nevertheless, you can see in the image curl is activated.

my local host display this:

any clue would be very much appreciated.

what does a simple phpinfo.php file in your root directory say ?


Thank you @hoernerfranz I don’t have any file named: phpinfo.php.
Do I need to create a file that file in the grav site root directory?


yes, you need to create it with the content I posted above.
then go to http://localhost/phpinfo.php and see what the webserver finds, especially curl.
you should get something like this:

Thank you!,
I don’t have that module I will find the way how to installed.

thanks a lot.

you’re welcome - so this looks like a bug or a misconfiguration in your WAMP installation.
you could also try XAMPP, if you don’t get curl to be included.

I found that there is a problem between PHP 7.4 and the Apache version. soon as Apache is updated to 2.4.46 the problem is solved.

All the best

@cidelab, I’ve taken the liberty to change which reply should be considered the ‘solution’. As you said yourself, upgrading Apache was the solution that solved the issue.

1 Like