Error when using cropZoom on an image

Hi there,

I’ve been using Grav for a few weeks now and I’ve just started trying to mess around with images, but I’ve encountered a snag.

If I place an image like so, it works fine:


But if I place an image like so, it just returns ERROR in place of the image:


I thought this might be due to the memory_limit in my php.ini being set too low (128MB), so I increased it to 256MB but it made no difference.

I then thought it might be due to the size of the uploaded image (around 3MB), so I resized the image and uploaded it as a new image, this time about 500KB, but cropZoom still produced the error whereas some other transformations I tried worked fine.

I have been clearing out the entire cache in between attempts, and using different image numbers each time to make sure there’s no issues due to caching.

I’m running my own server on DigitalOcean (Ubuntu 16.04.2, Nginx 1.10.0, PHP 7.0.15).

Does anyone have any idea how I might be able to get this working?

Thanks for looking.


Hi, could be a problem with the GD PHP extension. Can you check that it’s installed and enabled in your php config (/admin/config/info) ?

Thanks for the reply.

I just checked and I do have the GD extension enabled:


I just reinstalled php7.0-gd, restarted php-fpm and cleared my Grav cache, but it’s still the same error :frowning:

Just following up on this…

I’ve spun up another DigitalOcean droplet and installed Grav exactly as I did on my original droplet. I inserted an image into the text and the cropZoom function appears to work perfectly.

All I need to do now is find out why the new Grav installation is functioning differently to the existing one.

Oh god, I’m such an idiot.

The image link I was using had an erroneous " at the end of it:


… and that was causing it to produce ERROR.

Curiously, however, the additional double-quote mark when using cropResize did not cause it to fail:


Sorry for wasting anyone’s time!


Oh I didn’t notice that too! Glad it was a simple typo :slight_smile: