One-Page Site ERROR image instead of showcase.jpg

Hi there, since yesterday evening I have the problem, that when I upload the One-Page Skeleton, there is the error image (fallback.jpg) instead of the showcase.jpg. I tried alot of things, e. g.

  • deleting the cache
  • deleting everything, loading the skeletton from github instead of the getgrav page etc.

Nothing works. Any idea? Screenshot shows details. Bildschirmfoto 2015-05-22 um 12

P.S.: I am using grav on a hoster

Thanks to all - post closed - the problem was a to less RAM on my webserver package.

Glad you got it sorted, my next suggestion would to validate existence of libpng and libjpeg, and that would of required your hosting providers help too.

I’m having this trouble with a Grav site on a newly installed macbook pro running regular php and apache (i.e. not mamp app or anything).

I set my php.ini memory limit to 900M which I figured should have been heaps but still not working…

I installed libpng and libjpeg with brew. How do I test if these are working correctly?

Can’t work out what is wrong. There is nothing being written to Grav’s log (though it can because I forced it to error another thing to check).

Php access_log is giving these errors which should help: - - [13/Jun/2015:20:37:00 +1000] "GET /about HTTP/1.1" 200 7780 - - [13/Jun/2015:20:37:04 +1000] "GET /user/themes/antimatter/css/site.css HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /user/themes/antimatter/js/jquery-2.1.1.min.js HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /user/themes/antimatter/js/bootstrap.min.js HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /user/themes/antimatter/js/backstretch.js HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET  /images/f/a/l/l/b/fallback.jpg?a05dc40c HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /user/themes/antimatter/fonts/fontawesome-webfont.woff?v=4.0.3 HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /images/d/3/7/9/0/d379058442753cc1206844eb13d042c5bd1dd7f7-page-bg.jpe g?a05dc40c HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /images/e/c/3/2/e/ec32e0594bd5c6281dccc1f68ebb5cdf43ce164e-page-main.j peg?a05dc40c HTTP/1.1" 304 - - - [13/Jun/2015:20:37:04 +1000] "GET /site-logo.png HTTP/1.1" 200 13910 - - [13/Jun/2015:20:37:04 +1000] "GET /user/themes/antimatter/images/favicon.png HTTP/1.1" 200 6113

Plenty of the files in that access log are loading and working though…?

Nothing in php error_log

Oddly heaps of other images in my site are working fine with no problems at all, the only images affected are ones are these:

{{['team-geoff.png'].quality(95).html('','','img-responsive') }}


 {{['map-small.png'].quality(95).html('','','img-responsive') }}

Any ideas?

This site works fine on my iMac locally but running through MAMP (the app).


I also restarted apache and cleared grav cache between each test (changing memory limit etc).

Also updated Grav today.

I have plenty of other sites working on this setup, Grav is the last thing I haven’t got working and its only these images. I realised the images that are all working are all using the url type and running through the backstretch jquery plugin:

 $("#page-image-main").backstretch("{{['page-main.jpg'].cropZoom(1150,270).quality(95).url() }}");

I don’t think its memory, my hunch is that its’s something related to the PNG libraries. Are JPEG images working and PNGs not?

Another thing to just ‘try’ is to use just .html() see if that works before passing in attributes to the method.